D20326: Akonadiserver: rework handling of database deadlocks.
Daniel Vrátil
noreply at phabricator.kde.org
Sat Apr 6 23:56:37 BST 2019
dvratil requested changes to this revision.
dvratil added inline comments.
This revision now requires changes to proceed.
INLINE COMMENTS
> connection.cpp:49
>
> +#include <storage/dbdeadlockcatcher.h>
> +
Use "" instead of <>, it is a local include (while `private` is another library)
> connection.h:131
> private:
> + void parseStream(Protocol::CommandPtr cmd);
> template<typename T>
const&
> datastore.cpp:69
>
> -QThreadStorage<DataStore *> DataStore::sInstances;
> +static QThreadStorage<DataStore *> sInstances;
>
Not related, keep it in `DataStore`, please.
> dbdeadlockcatcher.h:48
> + } catch(const DbDeadlockException &except) {
> + if (recursionCounter == 5) {
> + throw;
Use a named constant instead of a magic number.
> transaction.cpp:20
>
> +#include "dbexception.h"
> #include "transaction.h"
Not needed.
REPOSITORY
R165 Akonadi
REVISION DETAIL
https://phabricator.kde.org/D20326
To: dfaure, dvratil, vkrause
Cc: kde-pim, dvasin, rodsevich, winterz, vkrause, mlaurent, knauss, dvratil
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-pim/attachments/20190406/637d5dae/attachment.html>
More information about the kde-pim
mailing list