[Kde-pim] Review Request 119096: Used the model in the composer.

Michael Bohlender michael.bohlender at kdemail.net
Thu Jul 3 08:00:13 BST 2014


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/119096/#review61522
-----------------------------------------------------------



mobile/api/mail/composer.h
<https://git.reviewboard.kde.org/r/119096/#comment42822>

    yes. renameing it to receiverModel is a good idea.



mobile/api/mail/composer.h
<https://git.reviewboard.kde.org/r/119096/#comment42821>

    whitespace ( QObject *p..... = 0 )



mobile/api/mail/composer.h
<https://git.reviewboard.kde.org/r/119096/#comment42824>

    maybe use a QScopedPointer instead.
    You can have a look at the Error Property in "message" to see how to use it.



mobile/api/mail/composer.cpp
<https://git.reviewboard.kde.org/r/119096/#comment42823>

    In KDE we usually use the initialisation list:
    
    Composer::Composer(QObject *parent) : QObject(parten), m_model(new Recei...
    
    


- Michael Bohlender


On July 3, 2014, 6:13 a.m., Abhijeet Nikam wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/119096/
> -----------------------------------------------------------
> 
> (Updated July 3, 2014, 6:13 a.m.)
> 
> 
> Review request for KDEPIM, Kevin Krammer and Michael Bohlender.
> 
> 
> Repository: kdepim
> 
> 
> Description
> -------
> 
> Added a slot addRecipients() to the composer. Used the model for input of values. Should I change name from model to receiverModel in Q_PROPERTY? Please ignore the receivermodel.cpp file. I have just corrected the coding style and added setRoleNames() , which was missing due to an incorrect commit.
> 
> 
> Diffs
> -----
> 
>   mobile/api/mail/composer.h fb6c7ef 
>   mobile/api/mail/composer.cpp dc9cafe 
>   mobile/api/mail/mailplugin.cpp 1b09b0b 
>   mobile/api/mail/receivermodel.cpp 5197e18 
> 
> Diff: https://git.reviewboard.kde.org/r/119096/diff/
> 
> 
> Testing
> -------
> 
> Done. Sent a mail using the values from model. Checked storage in model using qdebug().Used the following code for testing.
> 
> import org.kde.pim.mail 0.1 as Mail
> 
> Rectangle {
>   id: app
>   
>     Mail.Composer {
> 	id: composer
> 	from: "connect08nikam at gmail.com"
> 	subject: "test mail"
> 	body: "testing"
>     }
> 
>     ListView {
> 	model: composer.model 
>         width: 180
>         height: 100
> 	delegate: 
> 	    Text { text: model.email + ":" + model.type }
>   
>   }
> 
>     MouseArea {
> 	anchors.fill : parent  
> 	onClicked: {
> 	    composer.addRecipient ( "connect08nikam at gmail.com" , 1 )
> 	    composer.send()
> 	}
>     }
> 
>   
> }
> 
> 
> Thanks,
> 
> Abhijeet Nikam
> 
>

_______________________________________________
KDE PIM mailing list kde-pim at kde.org
https://mail.kde.org/mailman/listinfo/kde-pim
KDE PIM home page at http://pim.kde.org/



More information about the kde-pim mailing list