Phonon newbie problem

Yogesh Marwaha yogeshm.007 at
Sun Dec 9 12:03:00 GMT 2007

On 09/12/2007, Matthias Kretz <kretz at> wrote:
> On Sunday 09 December 2007, Yogesh Marwaha wrote:
> > I'm trying to use Phonon in my app (Qt4) but when it is run an error
> > "cannot create path" is generated. This also happens for tutorial2 in
> > Phonon svn, though amarok(4) works. (all are run in KDE3); but when I run
> > them in KDE4 they all work. What is the reason behind this behaviour? KDE4
> > still is not usable enough for me and so I want to use KDE3 and (still) use
> > Phonon. Any help will be appreciated.
> Hi,
> is "cannot create path" really the first error you get? I assume it's a
> follow-up error to "cannot create backend". QPluginLoader needs to find a
> plugin installed in the KDE4 prefix. To make it do that:
>   export QT_PLUGIN_PATH=$KDEDIR/lib/kde4/plugins
> startkde in KDE4 does it for you, that's why it works automatically. Also
> KApplication hardcodes the path and adds it to the library paths so that all
> KDE4 apps will work correctly regardless of the QT_PLUGIN_PATH being set.
> This will not be necessary anymore once Qt starts shipping backends...

Thanks for helpful reply, it works now.
BTW "cannot create path" was the first and only message thrown by phonon.

Yogesh M

More information about the kde-multimedia mailing list