arts 1.2.0-0+cvs20030512 and xmmarts

Lenar Lõhmus lenar at
Wed May 21 18:19:06 BST 2003


Tried this new arts version and xmmsarts plugin won't work with it.
When starting playback, it prints following:

GThread-ERROR **: GThread system may only be initialized once.

According to this backtrace:

0  0x401eda41 in kill () from /lib/
#1  0x4008d24b in pthread_kill () from /lib/
#2  0x4008d521 in raise () from /lib/
#3  0x401ee976 in abort () from /lib/
#4  0x4007659a in g_logv () from /usr/lib/
#5  0x400765bf in g_log () from /usr/lib/
#6  0x400622de in g_thread_init () from /usr/lib/
#7  0x409f4003 in Arts::StdFlowSystem::StdFlowSystem() () from=20
#8  0x409f672d in Arts::SetFlowSystem::startup() () from=20
#9  0x40df672a in Arts::StartupManager::startup() () from=20
#10 0x40ddd140 in Arts::Dispatcher::Dispatcher(Arts::IOManager*,=20
Arts::Dispatcher::StartServer) () from /usr/lib/
#11 0x4083eaae in arts_backend_init () from /usr/lib/
#12 0x4001855a in arts_init () from /usr/lib/
#13 0x40390a0e in artsd_open (fmt=3DFMT_S16_NE, rate=3D44100, nch=3D2) at=20
#14 0x40517811 in get_iplugin_info () from /usr/lib/xmms/Input/
#15 0x4008ad53 in pthread_start_thread () from /lib/
#16 0x4008ad99 in pthread_start_thread_event () from /lib/

=2E. it happens when #7 (flow/gslschedule.c) calls #6. And yes it's the sec=
call to g_thread_init. First one is made by xmms when it starts.

Shouldn't be there some check like g_thread_supported()? Actually I tried t=
but got segfault in gsl_thread_self() (at call to g_thread_self()) afterwar=

Can you pinpoint a simple workaraound/fix or is this more complicated?


Lenar Lõhmus

More information about the kde-multimedia mailing list