[KDE/Mac] Problems building Six

Jon Kleiser jon.kleiser at usit.uio.no
Sat Feb 7 13:14:41 CET 2009


I have just installed KDE on my Mac (OSX 10.5.5). I just installed the
five packages that I got from http://mac.kde.org/?id=download. I tried a
few of the applications (like konqueror.app), and they worked pretty OK.
My main goal with KDE on my Mac, however, was to be able to run the Hex
board game implementation called Six, which can be found here:
http://six.retes.hu/. I downloaded six-0.5.3.tar.gz. When I ran the
./configure, however, I got this:

checking build system type... i386-apple-darwin9.5.0
checking host system type... i386-apple-darwin9.5.0
checking target system type... i386-apple-darwin9.5.0
checking for a BSD-compatible install... /usr/bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for kde-config... not found
configure: error: The important program kde-config was not found!
Please check whether you installed KDE correctly.

I am a bit confused by the red Note on your Installation page. As far as I
can see, there are no .pkg files among the KDE packages that I've got. I
also tried this:
sudo /opt/kde4-deps/bin/update-kde-mac.sh
... but I obviously have no kde4-deps under /opt. It may have ended up
somewhere else ...

If anybody has success building Six on a Mac, I'd be happy to receive a
copy of the application.


Jon Kleiser

More information about the kde-mac mailing list