[kde-linux] [SOLVED] Re: Digikam and Gwenview cannot find kipi plugins

Bogus Zaba bogsub at bogzab.plus.com
Thu Jul 14 21:54:31 UTC 2011

On 07/13/2011 12:41 AM, Duncan wrote:
> Bogus Zaba posted on Tue, 12 Jul 2011 20:20:44 +0100 as excerpted:
>> OK - the ...services/kipiplugin_*.desktop files were all there - in the
>> same directory as you have them.
>> I then went on to the strace on gwenview and modifying slightly your
>> suggested command, ran:
>> strace -feopen gwenview 2>&1 | grep kipi
>> grepping out just the open files with "kipi" in the filenames...
>> output was quite simple:
>> open("/usr/lib/qt/lib/libkipi.so.7", O_RDONLY) = -1 ENOENT (No such file
>> or directory)
>> open("/usr/lib/libkipi.so.7", O_RDONLY) = 3
> That's all?  Wow.  I expected a whole slew.  But see below...
>> which I took to mean the first search for libkipi.so.7 failed (in the qt
>> sub-directory) but the second one (in /usr/lib/) worked OK. Check - that
>> file exists (it's a symlink to /usr/lib/libkipip.so.7.1.0) so that
>> appears to be OK. However what I notice in this directory is that this
>> file - libkipi.so.7.1.0 and its symlinks is old (March 2011) and was not
>> part of the install that my latest slackware package did. There is
>> another file (with symlinks) called /usr/lib/libkipiplugins.so.1.0.0
>> which *is* part of the latest install.
>> I guess I should remove / rename the old files - gwenview may then carry
>> on looking for the newer files (libkipiplugins rather than libkipi) and
>> the plugins might start up correctly?
> See the subthread Anne started.  There's a second package, libkipi (no -
> plugins) on my system, apparently libkipi-plugins on hers.  I was
> initially searching for kipi-plugins and didn't see it.
> Youre strace reveals that the actual plugins are dynamically loaded only
> when I click on the plugins menu, obviously after gwenview has already
> started.  Until I click on that menu, using your strace, only libkipi is
> loaded, with two strace/grep hits parallel to yours.
> ...I'm not sure where that leaves you on the problem, but we DO know that
> both libkipi.so and libkipiplugins.so are used, now.
OK, re-installing the kde-graphics package was all I needed to do. I 
kept thinking it was a kipi-plugins problem, but I gradually came to 
realise that it was more the KDE environment in which I was trying to 
use kipi-plugins. Plugins now appear in both Gwenview and Digikam.

More information about the kde-linux mailing list