[kde-linux] KDE 4. Trying to get it working like I need it to.

James Tyrer jrtyrer at earthlink.net
Thu Nov 12 09:50:18 UTC 2009

Dale wrote:
> James Tyrer wrote:
>> Dale wrote:
>>> James Tyrer wrote:
>>>> Dale wrote:
>>>>> Hi folks,
>>>>> I log into KDE 4 whenever there is a update to something just
>>>>> to see what is working and what issues still remain.  This is
>>>>> hopefully going to be the catch all thread for me.  Right
>>>>> now, I have two things that I want to work on.  There are
>>>>> others but this is two biggies.  I will say that after this
>>>>> last update, it is looking pretty darn cool.
>>>>> I'm using Gentoo.  I have both KDE 3.5 and KDE 4 installed.
>>>>> After yesterday, I have the latest updates that are available
>>>>> through Gentoo. Here are the versions of some of the software
>>>>> that may help in this:
>>>>> sqlite-2.8.16-r4 sqlite-3.6.18 kdelibs-4.3.3 
>>>>> akonadi-server-1.2.1 akonadi-4.3.3
>>>>> This is all the dbus related stuff:
>>>>> dbus-glib-0.76 (0) dbus-qt3-old-0.70 (0) 
>>>>> dbus-python-0.83.0-r1 (0) dbus-1.2.3-r1 (0) qt-dbus-4.5.3-r1
>>>>> (4)
>>>>> If it matters,
>>>>> gcc-4.4.2
>>>>> Problem one, I used to use Konqueror as root to edit config
>>>>> files and such.  I have to be root to do this.  I set Dolphin
>>>>> up to run as root and it comes up fine.  I even like the look
>>>>> so far.  The last time I tried this it wouldn't even open a
>>>>> folder, directory or whatever you want to call it.  It does
>>>>> after this latest update today.  I assume that got fixed.
>>>>> However, if I got to a directory like /etc ,which is owned by
>>>>> root, and try to open a text file, I get a error.  It won't
>>>>> let me copy and paste so it is a screen shot.  It basically
>>>>> complains about Klauncher and dbus.  Screen shot is attached
>>>>> as screenshot1.
>>>> Does it work if you open a Konsole and start it with:
>>>> kdesu dolphin
>>>> ?
>>>> Note that if you don't have a link that "kdesu" is, for some
>>>> strange reason" buried as: "$KDEDIR/lib/kde4/libexec/kdesu".
>>>> If you don't have a link, you might want to make one.  Name it
>>>> kdesu4 if you still have KDE-3 on the system.
>>> It doesn't work.  I get the same error about klauncher and D-Bus.
>>> It can go through directories tho.
>> Well the above works for me.  So, I would suspect that you have a
>> D-Bus configuration problem.  How did you install KDE-4?
>> You could open a Konsole from Konqueror (the one that is running as
>>  root) -- "Tools -> Open Terminal" -- and execute:
>> kdeinit4
>> and see if that helps.
> This may have helped.  I get this:
> root at smoker ~ # kdeinit4 kdeinit4: preparing to launch
> /usr/lib/libkdeinit4_klauncher.so kdeinit4: Communication error with
> launcher. Exiting! root at smoker ~ #
I have seen that error while starting Konqueror as root in a Konsole using:

	xhost + root
	su -
	{enter password}
	export DISPLAY

before I found out what happened to "kdesu".  And you might try that as
well.  The thing is that I never figured out what the problem was.  In
fact, I decided that it was a random error since closing that Konsole
instance and opening another and trying again always worked. :-(

> If it has a error like that, it may not be starting launcher when I 
> login either.  That could be the problem.
I still suspect D-Bus for my problem as well as yours.

> On D-Bus, I havnt't configured anything.  Gentoo takes care of all 
> that.  It is running and works for everything else. I dunno.
I just used the configure files in the BLFS manual.  There is one thing.
   As it says in the tutorial:


		[Shameless self promotion]

The "/etc/dbus-1/session-local.conf" file must be configured for it to
find your KDE-4 D-Bus services which are located in:


If you installed KDE-4 using Gentoo scripts, that should be configured
but you might want to check it.  So, for example, my KDE-4 is installed
in: "/usr/KDE-4" so I added this line:


to that file along with the other similar lines.  If you installed KDE-4
in "/usr" then you probably don't need to add anything.

James Tyrer

Linux (mostly) From Scratch

More information about the kde-linux mailing list