[kde-linux] KDE 4. Trying to get it working like I need it to.

James Tyrer jrtyrer at earthlink.net
Wed Nov 11 11:15:51 UTC 2009

Dale wrote:
> James Tyrer wrote:
>> Dale wrote:
>>> Hi folks,
>>> I log into KDE 4 whenever there is a update to something just to see
>>> what is working and what issues still remain.  This is hopefully going
>>> to be the catch all thread for me.  Right now, I have two things that I
>>> want to work on.  There are others but this is two biggies.  I will say
>>> that after this last update, it is looking pretty darn cool. 
>>> I'm using Gentoo.  I have both KDE 3.5 and KDE 4 installed.  After
>>> yesterday, I have the latest updates that are available through Gentoo. 
>>> Here are the versions of some of the software that may help in this:
>>> sqlite-2.8.16-r4
>>> sqlite-3.6.18
>>> kdelibs-4.3.3
>>> akonadi-server-1.2.1 
>>> akonadi-4.3.3
>>> This is all the dbus related stuff:
>>> dbus-glib-0.76 (0)
>>> dbus-qt3-old-0.70 (0)
>>> dbus-python-0.83.0-r1 (0)
>>> dbus-1.2.3-r1 (0)
>>> qt-dbus-4.5.3-r1 (4)
>>> If it matters,
>>> gcc-4.4.2
>>> Problem one, I used to use Konqueror as root to edit config files and
>>> such.  I have to be root to do this.  I set Dolphin up to run as root
>>> and it comes up fine.  I even like the look so far.  The last time I
>>> tried this it wouldn't even open a folder, directory or whatever you
>>> want to call it.  It does after this latest update today.  I assume that
>>> got fixed.  However, if I got to a directory like /etc ,which is owned
>>> by root, and try to open a text file, I get a error.  It won't let me
>>> copy and paste so it is a screen shot.  It basically complains about
>>> Klauncher and dbus.  Screen shot is attached as screenshot1.
>> Does it work if you open a Konsole and start it with:
>> 	kdesu dolphin
>> ?
>> Note that if you don't have a link that "kdesu" is, for some strange
>> reason" buried as: "$KDEDIR/lib/kde4/libexec/kdesu".  If you don't have
>> a link, you might want to make one.  Name it kdesu4 if you still have
>> KDE-3 on the system.
> It doesn't work.  I get the same error about klauncher and D-Bus.  It 
> can go through directories tho. 
Well the above works for me.  So, I would suspect that you have a D-Bus 
configuration problem.  How did you install KDE-4?

You could open a Konsole from Konqueror (the one that is running as 
root) -- "Tools -> Open Terminal" -- and execute:


and see if that helps.

James Tyrer

Linux (mostly) From Scratch

More information about the kde-linux mailing list