[kde-linux] KDE 4. Trying to get it working like I need it to.

Jan Simonson nytt at simonson.se
Tue Nov 10 15:43:59 UTC 2009

tisdag 10 november 2009 skrev Kevin Krammer:

> > When I change the command line in the program page in the Dolphin desktop
> >  file to:
> > kdesu 'dolphin %i -caption "%c" %u'
> > I get a request for root password and then Dolphin runs as root. However,
> >  when trying to invoke kwrite on any file I get:
> > KDEInit kunde inte starta "/usr/bin/kwrite" which translates to KDEInit
> >  could not start "/usr/bin/kwrite"
> > 
> > Starting Dolphin from a root shell when logged in as another user gives
> > the same result with some additional output after Dolphin is closed:
> > [root at oden ~]# dolphin
> > [root at oden ~]# kDebugStream called after destruction (from void
> > KDirWatchPrivate::removeEntry(KDirWatch*, KDirWatchPrivate::Entry*,
> > KDirWatchPrivate::Entry*) file
> > /builddir/build/BUILD/kdelibs-4.3.2/kio/kio/kdirwatch.cpp line 901)
> > Cancelled INotify (fd 10, 1) for "/root/.local/share"
> Can you try running
> dbus-launch dolphin
> in the root shell?

I tried that and it works ok, that is kwrite opens as I want it to.

However I also tried:
kdesu 'dbus-launch dolphin %i -caption "%c" %u'
in the command line in the program page in the Dolphin desktop file. That didn't 
work as Dolphin opens but I get the same KDEInit could not start 
"/usr/bin/kwrite" as before.

> I.e. explicitly starting a D-Bus session bus for the root session and
>  running  Dolphin with that.
> Could help to narrow down the problem.

Hope this helps in some way 

Jan Simonson

More information about the kde-linux mailing list