[kde-linux] KDE suddenly refuses to start

Ronald Fischer ynnor at mm.st
Mon Mar 9 14:03:49 UTC 2009

On one legacy system, I'm still running KDE 2. This worked fine so far, but one day,
after rebooting, when I did a startx, KDE refuses to start under my account. I can 
see that the X server gets initialized, but no sign of anything looking like KDE. 
Instead I find myself back on the command line. No error message on the screen.

I had a look at $HOME/.X.err, but I can only see the usual stuff until it says

  exec kde

and then "waiting for X server to shutdown".

>From this I conclude that the problem is with KDE, not with X.

I was looking for KDE specific log files, and I thought KDE would log something
somewhere below $HOME/.kde, but there are no logfiles under that directory.

Next I did a su root and started KDE, and this worked well, so it can't be that
the KDE installation itself got broken.

Any idea where I could look further for analyzing the problem?


Ronald Fischer <ronaldf at eml.cc>
+  If a packet hits a pocket on a socket on a port, 
+  and the bus is interrupted and the interrupt's not caught,
+  then the socket packet pocket has an error to report.
+		(cited after Peter van der Linden)

More information about the kde-linux mailing list