[kde-linux] KDE-3 session will not accept my root password

James Richard Tyrer tyrerj at acm.org
Mon Mar 2 19:16:37 UTC 2009

Anne Wilson wrote:
> On Monday 02 March 2009 16:52:13 James Richard Tyrer wrote:
>> Well this is really strange.  It goes without saying that this problem
>> started recently -- it worked before I updated some things on my system
>> (Berkeley DB, OpenSSL, & OpenLDAP).
>> And, now, when I am running KDE-3, it will not accept the root password.
>>   It works fine to log in with KDM or in a virtual terminal, but whether
>> I am trying to use su in a Konsole or using KDESU to run an application,
>> the result is: an "incorrect password" message.
>> I upgraded to OpenSSL-0.9.8j which didn't work and I had to revert to
>> OpenSSL-0.9.8g.
>> I currently have:
>> 	OpenLDAP-2.4.14
>> and am considering reverting to:
>> 	OpenLDAP-2.3.39
>> if anyone thinks that that could be the problem.  Or, I notice that FC
>> is using 2.4.12 with 5 recent patches (2.4.x).
> No idea, James, but I did have the problem once.  Of course it may be an 
> entirely different problem in your case.  See whether this helps:
> http://www.nabble.com/Can't-give-root-password-under-kde-td20397498.html

However, I have a slightly different error message.

I am starting to think that the problem is with the actual "su" command. 
  Since I tried to su in a virtual terminal and it didn't work there 
either.  I can log in as root but I can't log in as a user and then su.


More information about the kde-linux mailing list