[kde-linux] KDE 4 sound system still uses arts and doesn't work

James Richard Tyrer tyrerj at acm.org
Thu Jan 31 21:46:03 UTC 2008

Stefano Crocco wrote:
> Hello to everyone,
> I know this question might belong more to the Gentoo forum than here, but I 
> already tried asking there and I got no answer, so I'm trying here.
> I'm using KDE 4 (installed in parallel with KDE 3.5) on a Gentoo system with a 
> Realtek sound card (azalia compatible), using the snd_hda_intel kernel module, 
> and I can't get the sound system to work. The Sound System page in System 
> Settings only shows aRts in the Device Preference page, while KInfoCenter 
> says: "No information availlable about Soundcard". The result is that I hear 
> no sound.
> I think the problem lies in some wrong configuration of my sound card, since, 
> trying the SuSE KDE 4 live CD, everything worked perfectly (including the 
> sound card being listed instead of aRts in System Settings). Yet, looking at 
> the live CD /etc directory I couldn't find any relevant difference from the 
> Gentoo configuration. Searching google didn't yield any useful result, either.
The KDE4 sound system will NOT connect directly to hardware.  So, you 
need something (a sound server) running such as Jack, PulseAudio, ESD, 
etc.  Note, if using ESD, it doesn't seem to automatically start from KDE4.


More information about the kde-linux mailing list