[kde-linux] KDE4 + Qt4 compilation problems

James Richard Tyrer tyrerj at acm.org
Sun Jan 13 21:09:53 UTC 2008

Alexey Chernov wrote:
> Hello!
> I'm experiencing serious problems with KDE4 installation. I was really
> looking forward to building it and now it's finally released, but I
> can't build it.
> I built a fresh system using Linux From Scratch book. My architecture
> is x86_64-unknown-linux-gnu. I built both 32 and 64 bit toolchains,
> but most of libraries (including Xorg etc.) are 64 bit.
> The versions of tools in toolchain are: Binutils 2.18, GCC 4.2.2
> and Glibc 2.7. X.org is 7.3.
> I tried to build KDE4 from source code using "Getting Started" guide
> on kde.org. Before KDE4 release I prepared and built Qt 4.3.3 Open
> Source Edition. It compiled ok. But when I started to build kdelibs
> I received error message from CMake:
> "CMake Error: Qt compiled without support for -fvisibility=hidden.
> This will break plugins and linking of some applications.
> Please fix your Qt installation.
> -- Configuring done"

I built Qt-4.3.3 with:

.//configure -qt-gif -no-exceptions -debug -fast -prefix 
/usr/local/Trolltech/Qt-4 -no-cups -no-xinerama -no-tablet -qdbus -pch 
-nomake examples -nomake demos

{all one line}

and had no problems.

OTOH, I see no mention of your installing KDESupport or QCA before you 
tried to build KDELibs.


More information about the kde-linux mailing list