[kde-linux] 'End Session' problem

M K overlord_3d at hotmail.com
Tue Feb 12 12:01:38 UTC 2008

> From: cannewilson at googlemail.com
> To: gnome at hawaii.rr.com; kde-linux at kde.org
> Date: Sun, 10 Feb 2008 12:05:41 +0000
> Subject: Re: [kde-linux] 'End Session' problem
> On Sunday 10 February 2008 09:53:43 david wrote:
> > Anne Wilson wrote:
> > > On Sunday 10 February 2008 04:20:25 david wrote:
> > >> James Loughner wrote:
> > >>>>>> Just edit the /etc/X11/xorg.conf file and make vesa the driver.
> > >>>>>
> > >>>>> OK, tried it, and proved the point.  The display was, frankly, awful,
> > >>>>> but the 'End Session' worked perfectly.  Time to report a bug.
> > >>>>
> > >>>> James take a look at Bug #33095 at http://qa.mandriva.com/
> > >>>>
> > >>>> Edit /boot/grub/menu.lst, changing splash=silent to splash=verbose.
> > >>>> It's not clear why this works - the bug seems to be flgrx crashing on
> > >>>> the way out, so I don't see the connection - but several people have
> > >>>> confirmed that it worked for them.
> > >>
> > >> Running Debian Etch Lenny/Sid here. Checked by menu.lst, and no trace of
> > >> a "splash=" anything in mine.
> > >
> > > Do you have the problem?  We've identified that at least one version of
> > > SuSE does.  If you do, try adding "splash=verbose" and see if it makes
> > > any difference.
> >
> > I do have the problem. Where in menu.lst does "splash=verbose" go?
> Here is a section from mine
> title linux
> kernel (hd0,4)/boot/vmlinuz-laptop BOOT_IMAGE=linux root=/dev/hda5 
> resume=/dev/hda6 splash=verbose vga=788
> initrd (hd0,4)/boot/initrd-laptop.img

So, now I tried to do it - the menu.lst is just a link to grub.conf, so I wrote it into grub.conf, too :-) Now, it looks like this:
# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/sda1
#          initrd /boot/initrd-version.img
password --md5 'CENSORED ;-)'
title Fedora (
        root (hd0,0)
        kernel /boot/vmlinuz- ro root=LABEL=/ splash=verbose
        initrd /boot/initrd-
title Fedora (
        root (hd0,0)
        kernel /boot/vmlinuz- ro root=LABEL=/ splash=verbose
        initrd /boot/initrd-
After that, I asked a few people to login and logout - at all, they repeated login/logout 13 times, and X didn't crash but bravely returned to the login screen. 
But it already didn't crash so many times before... "Time will show" (c)

btw, when we're at the point as well - is there maybe something wrong in this xorg.conf?
# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

        RgbPath      "/usr/share/X11/rgb"
        FontPath     "/usr/share/X11/fonts"  # unix:7100 doesn't work any more, no idea why...

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "de"
        Option      "XkbVariant" "nodeadkeys"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Unprobed Monitor"
        HorizSync    31.5 - 97.9
        VertRefresh  50.0 - 70.0
        Option      "dpms"

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA Quadro FX 540"
        Option "RenderAccel" "True"
        Option "AllowGLXWithComposite" "true"
        Option "backingstore" "true"
        Option "TripleBuffer" "true"
        Option "AddARGBGLXVisuals" "True"

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x1024" "1280x960" "1024x768" "800x600" "640x480"

Section "DRI"
        Group        0
        Mode         0666

I would really appreciate if there really were something wrong... (The graphic card is an "VGA compatible controller: nVidia Corporation G72 [GeForce 7300 LE] (rev a1)" (source: lspci)). Is this maybe what's wrong?

Express yourself instantly with MSN Messenger! Download today it's FREE!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20080212/c704dc4a/attachment.html>

More information about the kde-linux mailing list