[kde-linux] KDE 4 sound system still uses arts and doesn't work

Stefano Crocco stefano.crocco at alice.it
Fri Feb 1 09:28:12 UTC 2008

Alle Thursday 31 January 2008, Kevin Krammer ha scritto:
> On Thursday 31 January 2008, James Richard Tyrer wrote:
> > Stefano Crocco wrote:
> > > Hello to everyone,
> > >
> > > I know this question might belong more to the Gentoo forum than here,
> > > but I already tried asking there and I got no answer, so I'm trying
> > > here.
> > >
> > > I'm using KDE 4 (installed in parallel with KDE 3.5) on a Gentoo system
> > > with a Realtek sound card (azalia compatible), using the snd_hda_intel
> > > kernel module, and I can't get the sound system to work. The Sound
> > > System page in System Settings only shows aRts in the Device Preference
> > > page, while KInfoCenter says: "No information availlable about
> > > Soundcard". The result is that I hear no sound.
> > >
> > > I think the problem lies in some wrong configuration of my sound card,
> > > since, trying the SuSE KDE 4 live CD, everything worked perfectly
> > > (including the sound card being listed instead of aRts in System
> > > Settings). Yet, looking at the live CD /etc directory I couldn't find
> > > any relevant difference from the Gentoo configuration. Searching google
> > > didn't yield any useful result, either.
> >
> > The KDE4 sound system will NOT connect directly to hardware.  So, you
> > need something (a sound server) running such as Jack, PulseAudio, ESD,
> > etc.  Note, if using ESD, it doesn't seem to automatically start from
> > KDE4.
> No, it depends on the configuration of the Phonon backend. I.e. xine or
> gstreamer can both output to several kinds of audio "sinks", including
> directly to ALSA without any sound daemon in between.
> Cheers,
> Kevin

Thanks to both of you

recently, I found out the reason arts was being listed in the device
preference page was that I had xine configured with support for it. I tried
removing this support, but this left no device availlable in SystemSettings. 
After reading James answer, I tried to install ESD, and it worked, even if 
the sound was very bad. 

I guess my problem is related to the xine configuration. Are there special 
settings needed to make xine work with phonon using alsa directly? I must add 
that xine seems to work correctly using alsa in amarok (both with KDE 3.5 and 

If I launch SystemSettings from a shell and switch to the sound system page, 
this is the message written to the console:

systemsettings(12631) MainWindow::selectionChanged: Comment:        "Sound System Configuration"
QMetaObject::indexOfSignal:KPageDialog: Conflict with KDialog::close()
systemsettings(12631)/kutils (KCModuleProxy) KCModuleProxyPrivate::loadModule: Module not already loaded, loading module  "Sound"  from library  "kcm_phonon"  using symbol  "kcm_phonon"
systemsettings(12631)/phonon (xine backend) Phonon::Xine::Backend::Backend: setting xine verbosity to 0
systemsettings(12631)/phonon (xine backend) Phonon::Xine::Backend::Backend: Using Xine version
systemsettings(12631)/phonon (xine backend) Phonon::Xine::XineEngine::checkAudioOutputs: isEmpty
QStringList Solid::Backends::Hal::HalManager::findDeviceByDeviceInterface(const Solid::DeviceInterface::Type&)  error:  "org.freedesktop.DBus.Error.ServiceUnknown"

systemsettings(12631)/phonon (xine backend) Phonon::Xine::XineEngine::checkAudioOutputs: outputPlugin:  alsa
systemsettings(12631)/phonon (audiodevicelist) Phonon::AudioDeviceEnumerator::availablePlaybackDevices: (
- "HDA ATI SB, ALC883 Digital (IEC958 (S/PDIF) Digital Audio Output)" ALSA ("iec958:CARD=SB,DEV=0") index: 1 preference: 30 avail: true advanced: true  )
systemsettings(12631)/phonon (xine backend) Phonon::Xine::XineEngine::checkAudioOutputs: outputPlugin:  file
systemsettings(12631)/phonon (xine backend) Phonon::Xine::XineEngine::checkAudioOutputs: outputPlugin:  none
systemsettings(12631)/phonon (xine backend) Phonon::Xine::XineEngine::checkAudioOutputs: 1 "HDA ATI SB, ALC883 Digital (IEC958 (S/PDIF) Digital Audio Output)" "alsa" ("iec958:CARD=SB,DEV=0")
systemsettings(12631)/kutils (KCModuleProxy) KCModuleProxyPrivate::loadModule: Module not already loaded, loading module  "Phonon Xine"  from library  "kcm_phononxine"  using symbol  "kcm_phononxine"
systemsettings(12631)/kutils (KCModuleProxy) KCModuleProxy::showEvent:

To me, it seems that my sound card is indeed found but, for some reason, it's not used.

Do you think this is a KDE-related problem or should I ask on the xine mailing list?



More information about the kde-linux mailing list