[kde-linux] Problem logging in as non-root user [SOLVED]

Bob McGowan bob_mcgowan at symantec.com
Tue Aug 12 16:02:11 UTC 2008

Neeraj Vaidya wrote:
> Hello Anne,
> In addition to my reply below , I would like to know if this
> problem has been reported on any other distribution ?
> Thanks,
> Neeraj

<--deleted on purpose-->

> The distro I am using has been created by me referencing LFS/BLFS books.

<--deleted on purpose-->

>  > SOLVED....This thread may be closed.
>  > Here is how :
>  > Created a symlink to the libs in /usr/X11R6/lib from /usr/lib

<--deleted on purpose-->

Since this is your own, home baked "distro", it's not likely this 
problem will be found in other distros.

I have no idea what the LFS/BLFS books say about this, but on Debian 
(which should be pretty close to what the books say) there's a file in 
/etc called 'ld.so.conf' which defines the "system" libraries that will 
be searched by 'ld.so' to resolve library calls.  The content on my 
system includes /lib, /usr/lib and /usr/X11R6/lib.

Changes to the content of the file require running the 'ldconfig' 
command to scan the defined library directories and setup the 
ld.so.cache file.

Bob McGowan
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3265 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20080812/39653af1/attachment.bin>

More information about the kde-linux mailing list