[kde-linux] Can't login via kde - hangs when "initializing peripherals"

david gnome at hawaii.rr.com
Wed Sep 13 20:28:44 UTC 2006

Maybe try starting FC with settings like nodma, etc. I've encountered 
these kinds of problems on my hardware with other distros. For some 
reason the motherboard's implementation of ACPI or some other such thing 
wasn't quite right.

David Scriven wrote:
> NFW!
> New user - same problem
> failsafe term then startkde - no problems
> removing files in /var/tmp & /tmp -didn't help
> removing font-cache-1 & ~/.ICEauthority didn't help
> I'm stumped - anybody have any idea what to do next?
> (other than a clean reinstall of FC5).
> DS
> --- David Scriven <davidwriter at yahoo.com> wrote:
>> No one can login via KDE, but I haven't tried creating
>> a new user. There is no ~/.xsession-errors file under any
>> id.
>> I'll try your other ideas tomorrow.
>> DS
>> --- Andrew Walbran <qwandor at gmail.com> wrote:
>>> On Sunday 10 September 2006 9:51 am, David Scriven wrote:
>>>> I'm having problem on a machine which has been working well
>>>> until a week or so ago. Running Fedora Core 5 updated from 4 some
>>>> months ago. Machine is kept up to date and currently has version
>>>> 3.5.4 of kde, kernel 2.6.17-1.2174, nvidia card using the livna
>>>> version of the drivers, version 8774.
>>>> When logging in under kde - it spends a long time at
>> "Initializing
>>>> peripherals" then there is some message, which appears too
>> briefly
>>>> to be seen, the screen blanks and then returns to the login
>> screen.
>>>> If I init 3, login via console & startx - kde works fine & goes
>>> through
>>>> the "initializing peripherals" section very rapidly.
>>>> I can login in under gnome - no problem.
>>>> If I try and login as root in kde, I find that any subsequent
>>> attempt
>>>> to login in (without a reboot) has problems because / has become
>>>> read-only, which I fix with a mount -o remount
>>>> I've tried deleting everything in /tmp & renaming ~/.kde -
>> doesn't
>>>> help. Nothing has been changed in the physical setup of this
>>> machine
>>>> in years.
>>>> I'd be grateful for any help/advice as I have no idea what to do
>>>> next or where to look for the error as nothing seems to be
>> logged.
>>> You could try looking in ~/.xsession-errors*.
>>> Try deleting or renaming ~/.fonts.cache-1, ~/.ICEauthority, and
>>> perhaps any 
>>> relevant files under /var/tmp/. Also, check for any files under
>> your
>>> home 
>>> directory which are not owned by you.
>>> Can other users on the same machine log in? What about if you
>> create
>>> a 
>>> completely new user?
>>> Another idea to try is to login to the 'failsafe' session, type
>>> 'startkde', 
>>> and watch for any helpful messages.
>>> -- 
>>> Andrew Walbran
>>> website: http://q.geek.nz/
>>> blog: http://qwandor.wordpress.com/
>>> ISPfind (find the best NZ broadband plan): http://ispfind.co.nz/

gnome at hawaii.rr.com
authenticity, honesty, community

More information about the kde-linux mailing list