[kde-linux] sound and corruption problem in Thunderbird Mail only in KDE

LPM lpm48 at yahoo.com
Fri Jul 7 14:49:15 UTC 2006

I have a rather strange problem with Thunderbird in KDE.  I
can not get the new mail sound to work.  If I select a custom sound and
then click on "preview sound", tbird freezes and then often will crash.
About the same time this started, I started to get abook.mab
corruption.  The usual garbage at the end of the file.  I can fix the
abook by removing the garbage, but it does get bothersome since it
happens about once a week.  I don't believe much in coincidences, so I
would suspect that the corruption occurs due to tbird trying to play a
sound.  This is on FC5.  I went to Fedora Lists first to see if anyone
there could help.  They tried to help, but we could not find a
solution.  They suggested I post here since it only happens in KDE.

Some background:

I have three computers, all are upgrades from FC3.  In two of them, the
new mail sound works fine.  I have all the latest updates, and all
systems are configured as close to the same as possible, although there
are slight differences due to their having different mixes of hardware.
On the problem system, tbird has no problem playing the new mail sound
in Gnome, it only happens in KDE.  All other sound related programs
work in KDE,  mplayer plays movies, xmms plays mp3s, system sounds
work.  I can double click the wav file in Konqueror and it plays fine. 
The wav file plays fine in noatun.

What I have tried:

I have esd enabled in Gnome, software mixer enabled in Gnome, KDE sound
system enabled, KDE hardware set to auto-detect, player settings set to
KDE sound system, kmix has all input types enabled.  I have toggled all
these setting on and off in different combinations, logged out,
rebooted, and nothing helps.  I have selected the system new mail sound
and it does nothing as well.

I logged in to another user running KDE, and the wav file plays fine in
Tbird on that account.  I went back into the problem account and
deleted the .thunderbird directory and let Tbird create a new one. 
Selected the wav file in the new mail sound preferences and tried a
preview.  No go.  I copied a .thunderbird directory from an account
where the sound works to the problem account, again, no sound, just

I ran alsamixer in a working account and the problem account and made
sure the settings were the same.  Made no difference.

I'm not sure what configuration files to look at in that account, and
no clue what to look for even if I knew which files to look at.  I hope
someone has a suggestion of what to look at next.


cmedia sound card in a PCI slot
1.6GHz Duron
Geforce 3 Ti200
512M DDR
Two 80G drives
KDE and Gnome as well as many of the devel packages

I'm sure that this is just some configuration problem, I just have run
out of ideas of where to look, and what to try.  I've made numerous
searches and have found a few others over the past year that have run
into the same exact problem, but no one ever posted a solution.  I hope
someone can point me in the right direction since this is the last
problem I have on these systems.

Thank you in advance,

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the kde-linux mailing list