[kde-linux] KDE 3.4.1 + X.org 6.8.2 + GeForce MX 4400 + nVidia modules = freeze... but not always!

Marcin 'golish' Goliszewski golish at niente.eu.org
Wed Sep 21 10:39:27 UTC 2005


I have a problem with which I haven't been able to cope for some time
now so I've decided to ask for help. First I tried to look for help on
some OS-specific (i.e. Debian-related) newsgroups and mailing lists but
with no success so I decided to ask on a KDE list. I hope you'll be
able to help me because I've used up already all of my ideas and I
don't have even a slightest idea what to check next.

Here's the problem:

I'm using KDE 3.4.1 installed from Debian packages available at Alioth:

I have a nVidia GeForce MX 4400 graphics card, namely:

golish at mala:/home/golish$ lspci | grep nVidia
0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)
golish at mala:/home/golish$

I'm using manufacturer's drivers with it which I've installed using
Debian's package system - the exact versions are:

golish at mala:/home/golish$ dpkg -l | grep nvidia
ii  nvidia-glx                       1.0.7174-4                      NVIDIA binary XFree86 4.x driver
ii  nvidia-kernel-2.6.12-1-k7        1.0.7174-4+2.6.12-5             NVIDIA binary kernel module for Linux 2.6.12
ii  nvidia-kernel-common             1.0.7174-1                      NVIDIA binary kernel module common files
ii  nvidia-kernel-source             1.0.7174-4                      NVIDIA binary kernel module source
ii  nvidia-settings                  1.0+20050525-1                  Tool of configuring the NVIDIA graphics driv
golish at mala:/home/golish$  

My Xserver is the newest X.org available in Debian Etch (testing), i.e.:

golish at mala:/home/golish$ dpkg -l | grep xserver-xorg
ii  xserver-xorg                     6.8.2.dfsg.1-6                  the X.Org X server
golish at mala:/home/golish$  

I'm using this configuration at this very moment which would suggest
that everything is working as it should, right? Well, wrong. The
problem is: I sit at the computer, log in (as an ordinary user of
course, I don't use the root account for everyday work what was
suggested earlier on a different list), use KDE as I want, do
everything I can imagine, launch every kind of app I can think of
(including OpenGL apps) - everything works perfectly, I couldn't wish 
nothing more. But when my sister or my father try to log in (using
different accounts of course) KDE hangs during startup. Similar
behaviour can be observed when using a newly created account (which is
assigned to the same system groups as my account and my family's
accounts; additionally no files outside of my $HOME directory are owned 
by me - I think this eliminates any possible differences in access rights 
to some files and/or directories) without any KDE-related config files 
(in fact, even without any files in the $HOME directory at all). After
logging in, the display manager (I'm using gdm but I've tried also kdm;
I've tried also logging in in text mode and then using startx - all
result in the same kind of freeze) passes control to KDE which begins
to start but almost immediately hangs, it even doesn't get far enough
to display the splash screen - all I can see is some weird bar in the
middle of the screen (a part of something which would be the splash
screen's progress bar if the session would proceed normally?). Here's
what I've found in the logs (namely in $HOME/.xsession-errors):

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:1.Xservers" -h "" -l ":1" "kg"
/etc/gdm/Xsession: Beginning session setup...
xset:  bad font path element (#143), possible causes are:
    Directory does not exist or has wrong permissions
    Directory missing fonts.dir
    Incorrect font server address or syntax
startkde: Starting up...

As you can see, it's not the most useful piece of information you could
wish to get... In the Xservers logs (i.e. Xorg.log) I see no anomalies
(everything is _identical_ to what I see after successfully logging in
as my user), display manager's logs are also completely clean. The only
trace of the problem can be found in dmesg:

NVRM: Xid: 13, 0001 02005600 00001796 00000c28 0203013a 00000080

After I log in nothing like this appears so I presume it's related to
the problem. "NVRM" would suggest a problem with the nVidia modules
which are known to hang Xserver in some situations. I know that one
solution would be to install an older version of the drivers - I've
checked that the problem doesn't exist when using drivers from the 6xxx
series. But I don't want this kind of solution - if one user can work
perfectly normally, I see no reason why others couldn't.

Well, everything suggests it's a graphics card-related problem so why
am I writing to a KDE list? The answer is simple: because KDE is the
only desktop environment/window manager that is causing trouble. I've
tried Ion3, I've tried some failsafe session consisting of only a
xterm, I've even tried GNOME - everything works perfectly for every user
I tried (even the newly added one). Apart from that - it's KDE's
processes the ones that hang - it can be seen in the strace's log of
startkde session which hanged (available here:
http://niente.eu.org/crap/startkde_strace.log.4 - caution: it's 697
KiB!). The log was made by putting the strace command (namely: 
'strace -fF -t -o startkde_strace.log startkde') into the
$HOME/.xsession script of the user whose KDE session hangs - it's the
best way I could think of but if it's not proper please feel free to
correct me.

The question is: what could I possibly have done 'wrong' that my 
sessions don't end up hanging and all the others' do? I suspect that the 
'magic' of this behaviour lays somewhere in my configuration files -
after removing them I get the same hang of KDE as all other users and 
after copying my config files to someone's else's $HOME he can 
'magically' use KDE without any problems at all. One important remark: 
the accounts which are not able to log in at this machine have a fully 
usable configuration - they are used on a daily basis on another machine 
(a thin client for which this machine acts as a server). 
But now: which configuration files could be the cause of this? Where 
should I look? Which settings/parameters/config files should I check?

I would be most grateful if you could point me a way to go because I
fill stupider with every day of trying to solve this problem...

Thanks in advance.

Best regards.

PS. English is not my native language so feel free to correct any
grammatical/spelling/punctuation/other errors.
 /---    Marcin     ||   Immortality is the   ---\
<=      'golish'    ||   only fate which is      =>
 \---  Goliszewski  ||   worse than death.    ---/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20050921/485707a0/attachment.sig>

More information about the kde-linux mailing list