[kde-linux] kmail- cannot start process pop3

dek neidorff kneidorf at gmail.com
Mon Aug 1 13:35:45 UTC 2005


On 7/29/05, dek neidorff <kneidorf at gmail.com> wrote:
> Hi all,
> I am running Fedora Core 3, KDE 3.3.1 and kmail 1.7.1 . On this
> computer, I have qmail/spamassassin/clamav running as the mail server
> for my network.  It works just fine.  (Installed via qmailrocks.org)
> Last weekend, mail appeared to stop coming in!  After some digging
> around, I found that yum (silly me for having it do automatic updates)
> had installed exim.  Stopping exim got mail back into the right place,
> but since then on startup (I have kmail set to check mail on startup)
> kmail posts the error "cannot start the process pop3".
> The netstat -plant command confirms that my pop server is running:
> tcp        0      0       *
>      LISTEN      9995/tcpserver
> (this is the server that came with qmail)  and in fact, I can telnet
> localhost 110 into the server and see my mail there.  My firewall is
> not blocking the pop3 access (confirmed by turning it off, briefly)
> and hosts.allow and hosts.deny are both empty.
> I can access my new mail via pine or squirrelmail, but I'd really
> rather be using kmail since I have a lot of stuff archived there.
> Please help me out of this mail stoppage.

I solved this problem with a lot of help from some very kind folks on
the net.  I case anyone else has the problem, here is what caused it
for me and how I solved it:

The kio_pop3.* files were removed from /usr/lib/kde3.  In my case, the
only thing that I could find that would do that was a massive fsck
session that I had recently.  The solution was to reinstall the
libraries from kdebase.xxxx.FC3.i386.rpm (xxxx reperesents your

More information about the kde-linux mailing list