[Kde-imaging] Proposed enhancement to KIPIPlugins::ImagesList

Luka Renko lure at kubuntu.org
Mon Dec 8 19:12:30 CET 2008


On Monday 08 December 2008 18:14:10 Andi Clemens wrote:
> enum ButtonStyle
> {
> ButtonsLeft,
> ButtonsRight,
> ButtonsBelow,
> NoButtons
> }

I like this. I would implement Right, Left and NoButtons for now, we can add 
more later.
Maybe we should name it ControlButtons?

> enum I_DONT_KNOW_A_GOOD_NAME_NOW
> {
> AutoLoad,
> AllowRaw
> }
>
> and put those two into the ctor
>
> ImagesList(parent, ButtonStyle, UNKNOWN_NAME :-))

I agree with Aurélien here: both options can be moved out of constructor. This 
would then look something like this:

   imgList = new ImagesList(parent, ButtonsLeft);
   imgList->setAllowRaw(true);
   imgList->loadImagesFromCurrentSelection();

I think autoLoad was anyhow just loading from current selection, therefore 
giving it more obvious name is better.
The only requirement is that setAllowRaw() is called first, otherwise they 
would not be loaded, but I think this should be pretty obvious.

If you are fine with above proposal, I am fine to make this change and update 
all plugins in extragear/graphics/kipi-plugins that use it. I anyway need 
proper change for SmugMug plugin, so I am more than interested to have this 
sooner than later. Review from Andi (and others) would still be appreciated. 
;-)

Regards,
Luka


More information about the Kde-imaging mailing list