[Kde-imaging] Can not compile libkipi anymore ;-(

Heiner Lamprecht heiner at heiner-lamprecht.net
Sun Feb 18 12:57:39 CET 2007


every now and than I make an svn-update of digikam, incl libkipi. 
But currently, it fails.  Even when I check out the clean sources
following the description on digikam.org, I have no success.

Compiling extragear/libs/ fails with:

/bin/sh ../../libtool --silent --tag=CXX --mode=link g++
  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
  -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -O2
  -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor
  -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE
  -o kipiplugin_viewer.la -rpath /opt/kde3/lib64/kde3
  -module ogl.lo texture.lo timer.lo plugin_viewer.lo plugin_viewer.moc.lo
  -lkipi -lGL

  cannot find -lkipi

collect2: ld returned 1 exit status

make[3]: *** [kipiplugin_viewer.la] Fehler 1

What can be the cause of the problem?


    heiner at heiner-lamprecht dot net    GnuPG - Key: 9859E373
  Fingerprint:  3770 7947 F917 94EF 8717 BADB 0139 7554 9859 E373

More information about the Kde-imaging mailing list