[Kde-imaging] Naming inconsistencies
aurelien.gateau at free.fr
Sat May 29 00:00:05 CEST 2004
Today I was looking at our current API and spotted a few inconsistencies in
the names we are using.
* Album vs ImageCollection
Our image container class is named ImageCollection, but we have some various
parts where we're speaking about Album. I think we should rename
ImageCollection to Album. This means the following changes:
ImageCollection -> Album
ImageCollectionShared -> AlbumShared
And also in the Interface class:
- currentAlbum -> currentView
* description vs comment
In the ImageInfo class, we have descriptions but the corresponding KIPI
features names it comments. Since we use comments in ImageCollection/Album, I
suggest we rename the description "property" in ImageInfo to comment.
If you agree on this, I volunteer to make the necessary changes in libkipi and
kipi-plugins. What would be the best way to rename ImageCollection? ask the
admin to rename the CVS files or just a plain cvs remove/cvs add ?
More information about the Kde-imaging