[Kde-hardware-devel] Review Request 111964: Basic declarative (QML) interface for Solid
Kevin Ottens
ervin at kde.org
Thu Aug 29 14:39:43 UTC 2013
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/111964/#review38863
-----------------------------------------------------------
What's funny is that it looks fairly close from the code which would have to be written for the "smart device list" I discussed with Alex a couple of years ago. It'd have to be split in two and then the part independent from QML would need to be thread safe.
Note: I'm not asking you to do that, it's just for future reference.
tier1/solid/src/imports/devices.h
<http://git.reviewboard.kde.org/r/111964/#comment28700>
Ah OK, I get where the confusion comes from. :-)
The property should be named "empty" the getter is still named "isEmpty".
tier1/solid/src/imports/devices.h
<http://git.reviewboard.kde.org/r/111964/#comment28701>
So isEmpty here.
tier1/solid/src/imports/devices.h
<http://git.reviewboard.kde.org/r/111964/#comment28702>
For now it'll be all in a single thread so you should be fine. But who knows what will come with Qt Quick 26 and KF42?? ;-)
tier1/solid/src/imports/devices.h
<http://git.reviewboard.kde.org/r/111964/#comment28703>
I think we generally put mutable on the same line than the rest of the declaration (kind of part of the type name).
- Kevin Ottens
On Aug. 29, 2013, 10:57 a.m., Ivan Čukić wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/111964/
> -----------------------------------------------------------
>
> (Updated Aug. 29, 2013, 10:57 a.m.)
>
>
> Review request for Solid, Àlex Fiestas, Aleix Pol Gonzalez, David Edmundson, and Kevin Ottens.
>
>
> Description
> -------
>
> revision 0:
>
> This one will need more review and discussion - it exposes some of Solid functionality to QML.
>
> The reason Solid classes are not exported directly is that they don't tend to have a no-arg constructor, and some of them are not QObjects.
>
> It registers a class (org.kde.solid.)Devices (initially modelled after DeviceNotifier) that contains the following features:
> - ability to list all devices or just those that match a defined query (Solid::Predicate)
> - signals for when devices that match the query are added or deleted
> - isEmpty property - are there no devices that match the query?
> - count property - the number of devices that match the query
> - devices property - a list of udis of the devices that match the query
> - device method that returns a QObject interface to the device.
>
> The things I'm in doubt about:
>
> 1. devices property and device(...) method are similarly named, while one gets udis, and the other actual DeviceInterface object.
>
> Possible solutions:
> - devices -> udis or deviceUdis
> - device(...) -> deviceInterface(...) or something else
>
> 2. If the user creates two instances with the same query, both instances will contain a query and a Solid::Predicate, the query will be parsed two times and similar.
>
> The implementation could be complicated a bit by creating private parts of instances with the same queries to be shared, but is it worth it?
>
> revision 1:
>
> Shared backends when two Devices objects have a same query.
>
>
> Diffs
> -----
>
> tier1/solid/src/CMakeLists.txt c3c462f
> tier1/solid/src/imports/CMakeLists.txt PRE-CREATION
> tier1/solid/src/imports/devices.h PRE-CREATION
> tier1/solid/src/imports/devices.cpp PRE-CREATION
> tier1/solid/src/imports/devices_p.h PRE-CREATION
> tier1/solid/src/imports/qmldir PRE-CREATION
> tier1/solid/src/imports/solidextensionplugin.h PRE-CREATION
> tier1/solid/src/imports/solidextensionplugin.cpp PRE-CREATION
>
> Diff: http://git.reviewboard.kde.org/r/111964/diff/
>
>
> Testing
> -------
>
> Yes. Created a test QML application.
>
>
> Thanks,
>
> Ivan Čukić
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-hardware-devel/attachments/20130829/b7677019/attachment-0001.html>
More information about the Kde-hardware-devel
mailing list