[Kde-hardware-devel] Fwd: Re: Trouble with udisks-daemon caused by solid

Kevin Ottens ervin at kde.org
Thu Jul 28 07:46:27 CEST 2011


Now that sounds more like a real issue.


----------  Forwarded Message  ----------

Subject: Re: Trouble with udisks-daemon caused by solid
Date: Wednesday 27 July 2011, 17:04:37
From: Andreas Roth <aroth at arsoft-online.com>
To: kde-core-devel at kde.org

On 2011-07-27 10:34, Kevin Ottens wrote:
> On Tuesday 26 July 2011 19:48:06 Andreas Roth wrote:
>> With the help of the amarok developers is found the piece of code, which
>> triggers this issue. In amarok/src/MediaDeviceCache.cpp, function
>> MediaDeviceCache::slotTimeout() calls Solid::Device::listFromType, which
>> does some dbus/udisks magic and this causes the trouble. I haven't gone
>> into the solid code to check what might be wrong there.
> Well, I guess the real question is why does Amarok poll in the first place?
> libsolid is doing what it's supposed to do: if you query a list is asks the
> system for it (in that case udisks). So obviously if you constantly ask the
> system you get the system component always eating CPU.
I don't know, but this you have to ask the amarok developers.

But one problem still remains:
udisks-daemon complains about a invalid command/messages. It returns the 

//org.freedesktop.DBus.Error.UnknownMethod:///Method \"GetAll\" with signature 
\"\" on interface//\"org.freedesktop.DBus.Properties\" doesn't exist

Any ideas on this one?


Kévin Ottens, http://ervin.ipsquad.net

KDAB - proud patron of KDE, http://www.kdab.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
Url : http://mail.kde.org/pipermail/kde-hardware-devel/attachments/20110728/63db7649/attachment.sig 

More information about the Kde-hardware-devel mailing list