[Kde-games-devel] Review Request 124022: Adding new feature to automatically increase ball size

Lamarque Souza lamarque at kde.org
Fri Jun 5 19:37:59 UTC 2015


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/124022/#review81246
-----------------------------------------------------------



kollision.kcfg (line 7)
<https://git.reviewboard.kde.org/r/124022/#comment55656>

    IncreaseBallSize



kollisionui.rc (line 14)
<https://git.reviewboard.kde.org/r/124022/#comment55657>

    increase_ball_size



mainarea.h (line 52)
<https://git.reviewboard.kde.org/r/124022/#comment55659>

    Why use const here? This variable should be named m_manBallDiameter. You can also add a comment stating that "man" means "player" in this code.



mainarea.h (line 67)
<https://git.reviewboard.kde.org/r/124022/#comment55660>

    ball size



mainarea.h (line 68)
<https://git.reviewboard.kde.org/r/124022/#comment55661>

    same here



mainarea.cpp (line 51)
<https://git.reviewboard.kde.org/r/124022/#comment55662>

    m_manBallDiameter



mainarea.cpp (line 64)
<https://git.reviewboard.kde.org/r/124022/#comment55663>

    What was changed here?



mainarea.cpp (line 68)
<https://git.reviewboard.kde.org/r/124022/#comment55664>

    ball size (twice).



mainarea.cpp (line 98)
<https://git.reviewboard.kde.org/r/124022/#comment55665>

    ball size



mainarea.cpp (line 191)
<https://git.reviewboard.kde.org/r/124022/#comment55666>

    You can add a commenting explaining what is happening here.



mainarea.cpp (line 529)
<https://git.reviewboard.kde.org/r/124022/#comment55667>

    add a space between "if" and "(".



mainarea.cpp (line 530)
<https://git.reviewboard.kde.org/r/124022/#comment55668>

    Add space before ande after "+". You can also add a comment stating that you are increasing ball size by 4 pixels here. Or am I wrong about that?



mainarea.cpp (line 532)
<https://git.reviewboard.kde.org/r/124022/#comment55669>

    space after ","



mainwindow.cpp (line 92)
<https://git.reviewboard.kde.org/r/124022/#comment55670>

    ball size



preferences.ui (line 23)
<https://git.reviewboard.kde.org/r/124022/#comment55671>

    ball size


- Lamarque Souza


On June 5, 2015, 7:06 p.m., Ícaro Jerry Salles Santana wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/124022/
> -----------------------------------------------------------
> 
> (Updated June 5, 2015, 7:06 p.m.)
> 
> 
> Review request for KDE Games, Filipe Saraiva, Lamarque Souza, and Sandro Andrade.
> 
> 
> Repository: kollision
> 
> 
> Description
> -------
> 
> Kollision is a game that the player drags a blue ball and tries to avoid colliding with red balls. This patch adds an option to automatically increase red balls size with objective to make the game more difficult.
> 
> 
> Diffs
> -----
> 
>   kollision.kcfg 53e60bb 
>   kollisionui.rc c64c19f 
>   mainarea.h 06a3032 
>   mainarea.cpp b7da2e4 
>   mainwindow.cpp cdc9966 
>   preferences.ui d1d8f64 
> 
> Diff: https://git.reviewboard.kde.org/r/124022/diff/
> 
> 
> Testing
> -------
> 
> The game compiles and the new feature works.
> 
> 
> Thanks,
> 
> Ícaro Jerry Salles Santana
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-games-devel/attachments/20150605/ecc8c7cf/attachment-0001.html>


More information about the kde-games-devel mailing list