[Kde-games-devel] A new highscore manager - KScoreManager

Dmitry Suzdalev dimsuzkde at gmail.com
Tue Apr 29 10:04:37 CEST 2008


On Tuesday 29 April 2008 05:37:18 Matt Williams wrote:
> Comments? Complaints? Insults?
Matt, it's really cool you've got to this! :)

Once I collected some suggestions about possible rewrite of our highscore API in an 
effort of rewriting it, but I still hadn't the time and motivation to continue that 
work (unfortunately).
So, can you please-please-please take a look at the page where I summarized all the 
input I received in that thread.
It's located here:

http://techbase.kde.org/Projects/Games/Ideas#Reworked_highscore_system

If I would speak as a KAtomic maintainer, I would say that most important thing there 
is to add support for the second type of highscores (which we currently have in 
katomic, kolf, kshisen). KAtomic still lacks highscore dialog support because of 
that.

Also, I think that Albert would be very happy to see i18n thing sorted out.
(I see you've already addressed it - cool!)

Now i've some comments for your current patch if you don't mind :)

- IMO, if you make class a singleton anyway, no need to make all functions static. Do 
them as usual, but make self() public. Then the class can be used as 
KScoreManager::self()->someFunction(). It's quite allright. it shows its singleton 
nature. Otherwise you're just emulating namespace...
And also add const modifier to functions as needed.
- Rename askName() to setAskName()
- Rename lessIsMore() to setLessIsMore()
- Getters for the above two?
- Use KGLOBAL_STATIC for implementing singleton (when you'll come to *.cpp)

Thanks for your work on this!

Cheers,
Dmitry.




More information about the kde-games-devel mailing list