[kde-freebsd] KDE upgrade to 4.7.2 fails

Dwayne MacKinnon dmk at ncf.ca
Wed Oct 19 13:13:23 UTC 2011

On October 19, 2011 01:04:25 AM Alberto Villa wrote:
> On Wed, Oct 19, 2011 at 5:47 AM, Dwayne MacKinnon 
<dmk at ncf.ca> wrote:
> > I ran into this one. You've got to make sure that
> > x11-toolkits/shared-desktop- ontologies is up to date, and then
> > re-install kdelibs4.
> What kind of tool are you using to update, people? May I suggest
> portmaster? It should avoid completely this type of errors.

I use portupgrade. Admittedly, I didn't follow UPDATING to the letter... I 
wiped out all of my kde* ports in addition to all the steps listed and 
then tried a portinstall x11/kde4. An upgrade of shared-desktop-
ontologies was not forced, and kdelibs4 built with barely a complaint. I 
keep a script running during major upgrades, and looking over the 
build output saw that it complained about not finding shared-desktop- 
ontologies and so it didn't build nepomuk support.


More information about the kde-freebsd mailing list