[kde-freebsd] dependencies

Olivier Smedts olivier at gid0.org
Thu Oct 13 09:42:05 UTC 2011

2011/10/13 Alberto Villa <avilla at freebsd.org>:
> A long (long) time ago...
> On Sun, May 22, 2011 at 9:46 AM, Schaich Alonso <alonsoschaich at gmx.de> wrote:
>> *when using WITH_DEBUG, deskutils/strigi should depend on devel/cppunit
> Will look into this. Or did you do it already, rakuco?
>> *devel/kdevplatform should not depend on multimedia QT_COMPONENTS
> rakuco applied it.
>> *x11/kdebase4-runtime and multimedia/kdemultimedia4 should probably only
>> depend on multimedia/xine if the later was selected as OPTION for x11/kde4
> Well, yes. Actually, there's no xine option anymore, as phonon-xine is
> deprecated. I think i'll make it optional, or a separate port, or
> whatever.

I still use it as my main phonon backend. That's the only one just
working, correctly. vlc backend is buggy as hell and makes phonon
crash, and gstreamer backend installs too much cr... dependencies. And
it doesn't read the flac files I can read with the xine backend
(default gstreamer install as a dependency, no special plugins

Nothing technical here, just saying xine backend is still a good option :)

Olivier Smedts                                                 _
                                        ASCII ribbon campaign ( )
e-mail: olivier at gid0.org        - against HTML email & vCards  X
www: http://www.gid0.org    - against proprietary attachments / \

  "Il y a seulement 10 sortes de gens dans le monde :
  ceux qui comprennent le binaire,
  et ceux qui ne le comprennent pas."

More information about the kde-freebsd mailing list