[kde-freebsd] CPU usage with network connection on 4.7.2

John Schneider john.a.schneider at gmail.com
Sat Nov 12 14:38:42 UTC 2011

Hi kde-freebsd group,

I've been having trouble with kde4-workspace and runtime ever since my
upgrade to 4.7.2 a few weeks ago.  The problem is related to having a
network connection and whenever I have one, the usage of all four of my CPU
cores max out. I'm running 9.0 RC1 with em network driver (chip=0x15028086

Before narrowing down the problem to a network connection, I assumed it was
a problem with me using gcc47 to compile, so  I tried:
- pkg_delete /var/db/pkg/* and installing everything from compiled source
with base gcc and -O2 -pipe

and when that didn't fix the problem, I tried:
- pkg_delete /var/db/pkg/* and installing everything from pkg_add -r

The problem still persists. Then I realized that when I started KDE with no
network connection, everything worked great (except for akonodi, which
always crashes when I shut down).  Within about 10 seconds of plugging in
my network cable, all four of my CPU cores max out.  If I kill the four
processes, then things are OK for a little while, but then knotify4 gets
triggered and all four cores max out again.  I've tried moving knotify4 to
another location.  That helps in that when I kill the processes that are in
deadlock, the problem only happens again when I open certain KDE apps
(plasma-desktop, dolphin, konq, etc.) and only 1 core will max out.

I have tried the following to fix the problem, but nothing has worked:
- Changed solid network backend from default wicd to Fake Net.
- Disable all KDE services having anything to with networking by manually
changing the .desktop files (I didn't trust the UI since I thought for sure
this would fix it, but it wasn't)
- Disable notification service

At this point, I've resorted to only connecting to the network when
necessary. I'm very frustrated and wishing I could easily go back to 4.6.
 Any advice you can offer would be greatly appreciated!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-freebsd/attachments/20111112/84048621/attachment.html>

More information about the kde-freebsd mailing list