[kde-freebsd] amarok-kde4 dies at start-up

Dima Panov fluffy at fluffy.khv.ru
Thu Jul 8 05:45:59 CEST 2010

On Thursday 08 July 2010 07:57:18 Rusty Nejdl wrote:
>  Rusty made some high-level suggestions, but would not follow-up
> explaining, how to perform them. But even if/when the suggestions are
> applied and work, the problem remains -- your port does not work "out of
> the box"...
>  Yours,
>  -mi
> Mikhail, 
> I may have missed an email you
> sent out later asking for explanation so can you please resend that as I
> don't recall anything nor any feedback from what I sent. 
> I am running
> this port out of the box without issue so we need to find what is
> different in your environment. That means you need to do some lifting
> here to help us find what is different in your system or we will not get
> any further.  
> What happened when you removed the file? For some
> reason, your system was unable to read it. I don't recall seeing any
> information to you about that file (size, permissions, type, etc) until
> now. 

I can guess. Amarok 2.3 can't use now embedded library from fresh mysql51 to init own 
internal database by innodb issue.

So only one way - revert to mysql50, build amarok, run it, configure it (no matter - 
external or internal db), switch back to mysql51 and rebuild amarok. It will use previously 
created database without any problems. 

All anger please route ro mysql developers, which broke compatibility :(

Dima "Red Fox" Panov @ Home | C73E 2B72 1FFD 61BD E206 1234 A626 76ED 93E3 B018
Khabarovsk, Russia          | 2D30 2CCB 9984 130C 6F87 BAFC FB8B A09D D539 8F29
KDE at FreeBSD Team | FreeBSD committer since 10.08.2009 | FreeBSD since Sept 1995
Twitter: fluffy_khv | Skype: dima.panov | Jabber.[org|ru]/GTalk/QIP: fluffy.khv

More information about the kde-freebsd mailing list