[kde-freebsd] [problem] Can't use Py Plasmoids due to undefined symbol

Deniz daimler3 at googlemail.com
Fri May 15 05:31:06 CEST 2009

Hey guys,

if I try to use python plasmoids, the only thing I get is an
black window which shows the following famous sentences:
"This Object could not be created for the following reason:
Could not create a python ScriptEngine for the gmail-plasmoid widget."

And it seems the error is coming from py-qt4-core.
I've tried the port version and I've tried the package version, but has
nothing helped.

Here is the error log of plasmoidviewer used with gmail-plasmoid (a python

plasmoidviewer(4482)/python (plugin): Failed to import module
> Traceback (most recent call last):
>   File
> "/usr/local/kde4/share/apps/plasma_scriptengine_python/pyappletscript.py",
> line 19, in <module>
>     from PyQt4.QtCore import *
> ImportError: /usr/local/lib/python2.5/site-packages/PyQt4/QtCore.so:
> Undefined symbol "_Py_TrueStruct"

Kdebindings4 cannot be installed and so I installed
I don't know if this is a kde-freebsd specific error since many people get
the "can not create script engine" error,
but some people who use other systems don't even get some errors in the

Hope I could help.

    Deniz Sarikaya
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.kde.org/pipermail/kde-freebsd/attachments/20090515/2186b943/attachment.htm 

More information about the kde-freebsd mailing list