[kde-freebsd] Fwd: [PATCH]GPGME 1.2.0 will break crypto in kdepim (Re: ports/135911: [MAINTAINER] security/gpgme: Update to version 1.2.0)

Wesley Shields wxs at FreeBSD.org
Thu Jul 2 16:01:11 CEST 2009

On Thu, Jul 02, 2009 at 10:25:31AM -0300, Carlos A. M. dos Santos wrote:
> On Thu, Jul 2, 2009 at 7:57 AM, Jason E. Hale<bsdkaffee at gmail.com> wrote:
> > On Wednesday 01 July 2009 11:07:04 Wesley Shields wrote:
> >> Does anyone care to comment on this? If the below text is applicable to
> >> FreeBSD I'd like to know so I can hold off on this update until fixes
> >> are in place. I'd hate to commit this after silence from the lists and
> >> then find out that things are broken.
> >>
> >> -- WXS
> >>
> >
> > After seeing the problem with KDE, I went through the source code of the rest
> > of the ports that use gpgme. ?The problem is that the new version of gpgme
> > requires that gpgme_check_version() is called before gpgme_new(). ?I have
> > identified several other ports that do not do this and I have developed
> > patches for them. ?They are as follows:
> [...]
> Thanks, Jason. I will give it a try tonight and submit a PR ASAP.

Feel free to submit them as a follow-up to this PR and I'll make sure
they are committed with the gpgme update.

-- WXS

More information about the kde-freebsd mailing list