[kde-freebsd] gpgme upgrade patch

Charlie Root root at ns.ael.RU
Sat Feb 7 04:13:48 CET 2009

       Greetings, Doug Barton!
        On Fri, Feb 06, 2009 at 18:47:16 -0800, You wrote:
     (dougb == Doug Barton)

dougb> > dougb> > On Thursday 05 February 2009 21:27:11 Doug Barton wrote:
dougb> > dougb> >> The attached patch upgrades gpgme to version 1.1.8. Since the kde
dougb> > dougb> >> components are the primary consumers of gpgme, I thought I'd ask y'all
dougb> > dougb> >> first to give this a test run.
dougb> > dougb> > 
dougb> > dougb> > Thanks!
dougb> > dougb> > 
dougb> > dougb> > Unfortunately the port does not build with option 'pth' enabled. Without 'pth' 
dougb> > dougb> > it builds fine.
dougb> > 
dougb> > The new gpgme builds fine with pth. Sticky Bit, update your pth package at first, please.
dougb> I built pth from the latest ports tree today and gpgme 1.1.8 didn't
dougb> build with my version of the port. Can you elaborate what you mean by
dougb> sticky bit?

Sticky Bit <stickybit at gmx.net> was a first author with gpgme-pth problem.

Anyway, gpgme 1.1.8 works with pth 2.0.7 (CVSuped ports tree about 18 hours ago)

$ls -d /var/db/pkg/pth*

$ls -d /var/db/pkg/gpgme*

$ ldd libgpgme-pth.so
    libpth.so.20 => /usr/local/lib/pth/libpth.so.20 (0x33dc5000)
    libgpg-error.so.0 => /usr/local/lib/libgpg-error.so.0 (0x33ddb000)
    libc.so.7 => /lib/libc.so.7 (0x33c90000)
    libintl.so.8 => /usr/local/lib/libintl.so.8 (0x33ddf000)
    libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x33f00000)

$uname -a
FreeBSD Fluffy.Khv.RU 8.0-800062-CURRENT FreeBSD 8.0-800062-CURRENT #0: Fri Feb
 6 13:37:27 VLAT 2009     root at Fluffy.Khv.RU:/usr/obj/usr/src/sys/Spot  i386

dougb> > Couple of gpgme-based applications builds and run like a charm.
dougb> > I'll be test kde4.2 apps as soon as possible.
dougb> That's great, thanks!

More information about the kde-freebsd mailing list