D29528: [OpenUrlJob] Improve comments/docs
David Faure
noreply at phabricator.kde.org
Fri May 8 13:02:26 BST 2020
dfaure added a comment.
Thanks!
INLINE COMMENTS
> openurljob.cpp:393
> + if (mime.isValid() && mimeName != m_mimeTypeName) {
> + m_mimeTypeName =mimeName;
> }
missing space after '='
> openurljob.cpp:590
> + const QMimeType mimeType = db.mimeTypeForName(m_mimeTypeName);
> + if (isExecutableMime(mimeType) && handleExecutables(mimeType)) {
> + return;
That one was on purpose. I find this version less readable, mixing a test and an actual action (with error handling).
> openurljob.h:114
> * Starts the job.
> - * You must call this, after having done all the setters.
> + * You must call this, after having called all the needed setters.
> * This is a GUI job, never use exec(), it would block user interaction.
I think I used the sentence in the two LauncherJobs, feel free to make the same change here.
REPOSITORY
R241 KIO
REVISION DETAIL
https://phabricator.kde.org/D29528
To: ahmadsamir, #frameworks, dfaure
Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20200508/8de8b2f8/attachment.htm>
More information about the Kde-frameworks-devel
mailing list