D26484: Add KIO::DelayPopup flag and DropJob::menuPopup()

David Faure noreply at phabricator.kde.org
Sat Jan 11 21:11:54 GMT 2020


dfaure requested changes to this revision.
dfaure added a comment.
This revision now requires changes to proceed.


  I agree with the approach. Just naming needs to be improved.
  
  I'd call the method "showMenu" or "showPopup".
  DelayPopup hints at a builtin timer, better call it something like DontShowPopup (even though some people don't like negative flags). ManualShowPopup? ExplicitShowPopup?
  And it shouldn't be in the job_base.h enum, which can be used by all jobs.
  Better add something to DropJob specifically.
  
  The new method also needs docu including @since.
  
  Thanks!

INLINE COMMENTS

> dropjob.cpp:416
> +
> +void DropJob::menuPopup(const QPoint &p, QAction *atAction) {
> +    Q_D(DropJob);

This '{' goes on its own line.

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D26484

To: trmdi, #frameworks, davidedmundson, elvisangelaccio, mart, dfaure
Cc: ngraham, broulik, anthonyfieroni, kde-frameworks-devel, LeGast00n, GB_2, michaelh, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20200111/81ad5c92/attachment.html>


More information about the Kde-frameworks-devel mailing list