D26407: KFileItem: Improve isSlow to not block when a network mount is unresponsive, make SkipMimeTypeFromContent skip only on slow fs
David Faure
noreply at phabricator.kde.org
Sat Feb 8 09:18:48 GMT 2020
dfaure requested changes to this revision.
dfaure added a comment.
This revision now requires changes to proceed.
The approach makes sense to me.
INLINE COMMENTS
> kmountpoint.cpp:420
> +#else
> + const QString realname = path;
> #endif
You should rename this variable, it's no longer the result of canonicalFilePath() (also called "realpath" in glibc).
> kmountpoint.h:45
> + * making this function non-blocking, or try to return the real final mount point potentially blocking
> + * if a network filesystem is unresponsive
> + */
Missing @since
> kmountpoint.h:68
> */
> - Ptr findByPath(const QString &path) const;
> + Ptr findByPath(const QString &path, FindByPathFlag flag = RealMountPoint) const;
>
This is BIC, you changed the signature of an existing exported method.
You need to overload it, instead.
i.e. add a method with two args, and a comment like
// TODO KF6 merge with the above method using RealMountPoint as default value
(and a @since flag of course)
REPOSITORY
R241 KIO
REVISION DETAIL
https://phabricator.kde.org/D26407
To: meven, #frameworks, ngraham, broulik, dfaure
Cc: anthonyfieroni, kde-frameworks-devel, LeGast00n, cblack, GB_2, michaelh, ngraham, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20200208/1ead2c0b/attachment.html>
More information about the Kde-frameworks-devel
mailing list