D29256: [server] Introduce mapped() signal
Aleix Pol Gonzalez
noreply at phabricator.kde.org
Tue Apr 28 18:59:06 BST 2020
apol added a comment.
+1
INLINE COMMENTS
> surface_interface.cpp:333
> const bool childrenChanged = source->childrenChanged;
> + const bool visibilityChanged = bool(source->buffer) ^ bool(target->buffer);
> bool sizeChanged = false;
Using != would probably be more readable and accurate (we're don't need it to be bitwise, we're assuming bool changes it to 00001 or 00000).
REPOSITORY
R127 KWayland
BRANCH
introduce-mapped-signal
REVISION DETAIL
https://phabricator.kde.org/D29256
To: zzag, #kwin, davidedmundson
Cc: apol, kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20200428/f3502d39/attachment.html>
More information about the Kde-frameworks-devel
mailing list