D21249: Test current filter before setting a new one
Elvis Angelaccio
noreply at phabricator.kde.org
Sun May 19 09:50:20 BST 2019
elvisangelaccio added inline comments.
INLINE COMMENTS
> kfilewidget.cpp:132
> void updateLocationEditExtension(const QString &);
> + bool matchFilter(const QString &filename, const QString &filter, const bool bUpdate);
> void updateFilter();
Nitpick: I'd make `filter` the first parameter. And we usually don't use `const boll` in signatures, but just `bool`.
`bUpdate` doesn't tell the reader what this variable is used for. How about calling it `updateCurrentFilter` or similar?
REPOSITORY
R241 KIO
REVISION DETAIL
https://phabricator.kde.org/D21249
To: jglogowski, #frameworks, ngraham
Cc: elvisangelaccio, ngraham, michaelweghorn, kde-frameworks-devel, michaelh, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20190519/01d07a37/attachment.html>
More information about the Kde-frameworks-devel
mailing list