D26127: Simplify cppType method: Return Early, Use a Map and Assert.

Tomaz Canabrava noreply at phabricator.kde.org
Mon Dec 23 18:42:07 GMT 2019


tcanabrava added a comment.


  In D26127#582296 <https://phabricator.kde.org/D26127#582296>, @ervin wrote:
  
  > Those data structure look really similar to the ones you introduced in param() for D26126 <https://phabricator.kde.org/D26126>. It looks like we'll end up with a Q_GLOBAL_STATIC or such instead of code duplication.
  
  
  it's similar but the values are different, the other one is for parameters, this one for return types, so on the other one we have `const QList<QUrl> &` and here is just `QList<QUrl>`.
  I tougth in a way to make them both be the same, but I couldn't find a way, since some elements will not have the `const &` in both cases, like int, uint, double, I prefered to keep the maps separated.

REPOSITORY
  R237 KConfig

REVISION DETAIL
  https://phabricator.kde.org/D26127

To: tcanabrava, ervin
Cc: ervin, kde-frameworks-devel, LeGast00n, GB_2, michaelh, ngraham, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20191223/1d84de6b/attachment.html>


More information about the Kde-frameworks-devel mailing list