D20524: [FileMetaDataWidget] Allow inline configuration of visible properties

Elvis Angelaccio noreply at phabricator.kde.org
Sun Apr 14 13:01:29 BST 2019


elvisangelaccio added inline comments.

INLINE COMMENTS

> filemetadatawidget.cpp:53
>      {
> +        QCheckBox* check;
>          QLabel* label;

I'd call it `checkBox` for better clarity.

> filemetadatawidget.cpp:113-114
>          row.value->deleteLater();
> +        if (row.check)
> +            row.check->deleteLater();
>      }

Missing braces

> filemetadatawidget.h:47-49
> +    ReStart = 0,
> +    Accept,
> +    Cancel

Can you add some apidox for this enum? In particular, it's not so clear what `ReStart` is used for.

REPOSITORY
  R824 Baloo Widgets

REVISION DETAIL
  https://phabricator.kde.org/D20524

To: bruns, #baloo, #dolphin, #frameworks, ngraham, astippich
Cc: elvisangelaccio, gennad, domson, ashaposhnikov, astippich, spoorun, abrahams
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20190414/6521703f/attachment-0001.html>


More information about the Kde-frameworks-devel mailing list