D10918: taglibextractor: Refactor for better readability

Michael Heidelbach noreply at phabricator.kde.org
Wed Mar 14 22:04:33 UTC 2018


michaelh added inline comments.

INLINE COMMENTS

> taglibextractor.cpp:157
> +    if (itAlbumArtists != allTags.end()) {
> +        data.albumArtists = itAlbumArtists->second.toStringList().toString(", ");
>      }

This is an example for what we're discussing. Why the join??? We might lose info, when the album artist contains a comma.

REPOSITORY
  R286 KFileMetaData

REVISION DETAIL
  https://phabricator.kde.org/D10918

To: michaelh, mgallien, #baloo, #frameworks, astippich
Cc: astippich, ashaposhnikov, michaelh, spoorun, nicolasfella, ngraham, alexeymin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20180314/194b78d0/attachment.html>


More information about the Kde-frameworks-devel mailing list