D6831: Make use of kauth helper in methods of file ioslave

David Faure noreply at phabricator.kde.org
Thu Jan 4 08:46:52 UTC 2018


dfaure accepted this revision.
dfaure added inline comments.

INLINE COMMENTS

> file.cpp:304
> +        bool dirCreated;
> +        if (!(dirCreated = QDir().mkdir(path))) {
> +            if (auto err = execWithElevatedPrivilege(MKDIR, path)) {

moving this to the line above would be simpler / more readable:

  bool dirCreated = QDir().mkdir(path);
  if (!dirCreated) {

REPOSITORY
  R241 KIO

BRANCH
  master

REVISION DETAIL
  https://phabricator.kde.org/D6831

To: chinmoyr, dfaure, #frameworks
Cc: dhaumann, #frameworks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20180104/b3c63c7e/attachment.html>


More information about the Kde-frameworks-devel mailing list