D8450: User can now hide an entire places group from KFilePlacesView

Kevin Ottens noreply at phabricator.kde.org
Tue Oct 31 12:21:46 UTC 2017


ervin requested changes to this revision.
ervin added a comment.
This revision now requires changes to proceed.


  At least the unit test would be welcome, I let you decide on the other comment.

INLINE COMMENTS

> kfileplacesmodel.cpp:329
>  
> +QModelIndexList KFilePlacesModel::groupIndexes(const KFilePlacesModel::GroupType type) const
> +{

Would be nice to unit test that guy

> kfileplacesview.cpp:863-866
> +            if (d->itemDisappearTimeline.state() != QTimeLine::Running) {
> +                delegate->setDisappearingItemProgress(0.0);
> +                d->itemDisappearTimeline.start();
> +            }

This duplicates code from the next if branch below... I wonder if before or after that commit we shouldn't try to refactor that and remove some of the code duplication around the delegate animation use?

REVISION DETAIL
  https://phabricator.kde.org/D8450

To: mlaurent, ngraham, renatoo, franckarrecot, ervin
Cc: #frameworks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20171031/c68135bd/attachment.html>


More information about the Kde-frameworks-devel mailing list