D7968: WIP: Forward QComboBox signals instead of QComboBox lineedit signals
Aleix Pol Gonzalez
noreply at phabricator.kde.org
Sun Nov 19 22:59:46 UTC 2017
apol requested changes to this revision.
apol added inline comments.
This revision now requires changes to proceed.
INLINE COMMENTS
> kurlrequester.cpp:132
>
> - connect(sender, SIGNAL(returnPressed()),
> - receiver, SIGNAL(returnPressed()));
> - connect(sender, SIGNAL(returnPressed(QString)),
> - receiver, SIGNAL(returnPressed(QString)));
> + connect(combo, static_cast<void (KComboBox::*)()>(&KComboBox::returnPressed),
> + receiver, static_cast<void (KUrlRequester::*)()>(&KUrlRequester::returnPressed));
We can use qOverload now (we depend on Qt 5.7). It will end being much more readable.
REPOSITORY
R241 KIO
REVISION DETAIL
https://phabricator.kde.org/D7968
To: mwolff, apol
Cc: apol, #frameworks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20171119/1da039b4/attachment.html>
More information about the Kde-frameworks-devel
mailing list