D5877: Use absolute path instead of "." as path to watch

David Faure noreply at phabricator.kde.org
Sun May 21 11:44:18 UTC 2017


dfaure requested changes to this revision.
dfaure added inline comments.
This revision now requires changes to proceed.

INLINE COMMENTS

> kdirwatch_unittest.cpp:115
>      void stopAndRestart();
> +    void bug374075();
>  

I prefer more descriptive method names (the bug number as a comment next to the implementation).

> kdirwatch_unittest.cpp:760
> +    watch.addDir(QDir::homePath());
> +    // NOTE: addDir(".") it's not enough, we really need this path to trigger the bug.
> +    watch.addDir(QStringLiteral(":/kio5/newfile-templates"));

Where does ":/foo" become "." then?
Why not catch ":/foo" rather than check for "." after some unknown conversion somewhere? Feels fragile.

REPOSITORY
  R244 KCoreAddons

REVISION DETAIL
  https://phabricator.kde.org/D5877

To: elvisangelaccio, dfaure
Cc: #frameworks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20170521/4507dfb8/attachment.html>


More information about the Kde-frameworks-devel mailing list