D4911: add Baloo DBus signals for moved or removed files
Aleix Pol Gonzalez
noreply at phabricator.kde.org
Fri Mar 3 10:59:50 UTC 2017
apol added inline comments.
INLINE COMMENTS
> metadatamover.cpp:47
> +{
> + auto childrenIds = tr.childrenDocumentId(parentId);
> +
make const
> metadatamover.cpp:49
> +
> + for (auto oneChildren : childrenIds) {
> + fileList.push_back(QFile::decodeName(tr.documentUrl(oneChildren)));
const auto &
> metadatamover.cpp:83
> + QVariantList vl;
> + vl.reserve(1);
> + vl << QVariant(fileList);
That `reserve` is wrong, it should be 3.
How about this?
`message.setArguments({QVariant(fileList), from, to});`
> metadatamover.cpp:128
> + vl << QVariant(fileList);
> + message.setArguments(vl);
> +
This would be much more readable using the initializer syntax.
REPOSITORY
R293 Baloo
REVISION DETAIL
https://phabricator.kde.org/D4911
To: mgallien
Cc: apol, #frameworks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20170303/5db84b91/attachment-0001.html>
More information about the Kde-frameworks-devel
mailing list