Review Request 127111: kurlnavigator: add new signal selectParentOfPreviousUrl
Gregor Mi
codestruct at posteo.org
Thu Jul 27 11:15:34 UTC 2017
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/127111/
-----------------------------------------------------------
(Updated July 27, 2017, 11:15 a.m.)
Review request for KDE Frameworks, Emmanuel Pescosta and Frank Reininghaus.
Changes
-------
* Rename urlutil.h to urlutil_p.h
* Remove include QDebug which is no longer used
* Rename local variables to better reflect the meaning (childPath, parentPath)
* Remove confusing or useless comments; fix other comments
* unit test: Move urlutil test from tests to autotest
* unit test: Replace ugly _LURL_ preprocessor macro with inline function
* unit test: remove plain wrong call of QUrl::fromLocalFile with a path containing an URL scheme
* unit test: add a test with # in the path to find potential path/url confusion in the code
* unit test: all tests pass
Bugs: 335616
https://bugs.kde.org/show_bug.cgi?id=335616
Repository: kio
Description
-------
Moved logic from https://git.reviewboard.kde.org/r/123253 to here.
Provides a signal to implement bug https://bugs.kde.org/show_bug.cgi?id=335616: "Dolphin: Navigate to parent folder selects child folder".
Diffs (updated)
-----
autotests/CMakeLists.txt 83b7b73b4b92e09076ece2d4618559ddb8089368
autotests/urlutiltest.cpp PRE-CREATION
src/filewidgets/kurlnavigator.h ff155c7bbdc8c72f579f730993286a4dccae6338
src/filewidgets/kurlnavigator.cpp 033046f06dd5bea3f4124669c55803aba3a31789
src/filewidgets/urlutil_p.h PRE-CREATION
Diff: https://git.reviewboard.kde.org/r/127111/diff/
Testing
-------
Thanks,
Gregor Mi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20170727/47ca7c72/attachment.html>
More information about the Kde-frameworks-devel
mailing list