[Differential] [Commented On] D4607: finish support for opening compressed packages
Eike Hein
noreply at phabricator.kde.org
Thu Feb 16 11:13:28 UTC 2017
hein added inline comments.
INLINE COMMENTS
> package.cpp:362
> foreach (const QString &contentsPrefix, d->contentsPrefixPaths) {
> - const QString prefix = fileType == "metadata" ? d->path : (d->path + contentsPrefix);
> + const QString prefix = !d->tempRoot.isEmpty() ? (fileType == "metadata" ? d->tempRoot : (d->tempRoot + contentsPrefix)) : (fileType == "metadata" ? d->path : (d->path + contentsPrefix));
>
Could you rewrite this for readability a bit? Nested ternary operators just to use a diff var name is ugly, we have implicitly shared strings :)
REPOSITORY
R290 KPackage
REVISION DETAIL
https://phabricator.kde.org/D4607
EMAIL PREFERENCES
https://phabricator.kde.org/settings/panel/emailpreferences/
To: mart, #plasma, hein
Cc: plasma-devel, #frameworks, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20170216/354c104a/attachment-0001.html>
More information about the Kde-frameworks-devel
mailing list