Review Request 128353: Unit tests of directory permissions in zip files
David Faure
faure at kde.org
Sun Jul 3 20:25:32 UTC 2016
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/128353/#review97066
-----------------------------------------------------------
Fix it, then Ship it!
autotests/karchivetest.cpp (line 1113)
<https://git.reviewboard.kde.org/r/128353/#comment65570>
QVERIFY(!data.isEmpty());
(I'd rename data to file, it's a filename, not file contents)
autotests/karchivetest.cpp (line 1118)
<https://git.reviewboard.kde.org/r/128353/#comment65569>
Why QLatin1String("") and not just QString() ?
autotests/karchivetest.cpp (line 1119)
<https://git.reviewboard.kde.org/r/128353/#comment65568>
There's a join(QChar), so better write join(' ').
- David Faure
On July 3, 2016, 1:09 p.m., Sune Vuorela wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/128353/
> -----------------------------------------------------------
>
> (Updated July 3, 2016, 1:09 p.m.)
>
>
> Review request for KDE Frameworks and David Faure.
>
>
> Repository: karchive
>
>
> Description
> -------
>
> Add unit test to prevent later changes to abandon directory permissions in zip files
>
> Test file created with
> mkdir ziptest
> cd ziptest
> mkdir 700 750 755
> chmod 700 700
> chmod 750 750
> chmod 755 755
> zip -r my.zip 7*
>
>
> Diffs
> -----
>
> autotests/karchivetest.h 5a6375c
> autotests/karchivetest.cpp dd03dac
>
> Diff: https://git.reviewboard.kde.org/r/128353/diff/
>
>
> Testing
> -------
>
>
> Thanks,
>
> Sune Vuorela
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20160703/ecbbab02/attachment.html>
More information about the Kde-frameworks-devel
mailing list